Меню
Меню

1с альфа авто ошибка при загрузке компоненты управления оборудованием

Ошибка загрузки компоненты управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Добрый день! Конфигурация Альфа-авто 5.1.09.09, Server 2008 R2, после обновления платформы на 8.3.11.2924 (x64) при запуске появляется сообщение «Ошибка при загрузке компоненты управления оборудованием. «
Пробовал следующее:
-Регистрировал/перерегистрировал компоненту как указано в данной теме
-Пользователя usr1cv8 включил в группу администраторов
-Запускал 1с от имени администратора

Результатов нет. Куда копать дальше?

Цитата
Светлана Сулименко написал:
Светлана, 1С запускается именно из папки ProgramFiles(x86), а в папке ProgramFiles 1С как раз блокирует регистрацию компоненты, поэтому удаление папки 1cv8 из ProgramFiles и решит проблему.
Цитата
Светлана Сулименко написал:
Добрый день, Дмитрий, Вам нужно ставить полную версию платформу 1С, в которой есть компоненты и для 32 битной и для 64 битной версии, тогда у Вас будет возможность зарегистрировать компоненту.
Цитата
Светлана Сулименко написал:
https://releases.1c.ru/version_file?nick=Platform83&ver=8.3.12.1412&path=Platform\8_3_12_1412\windows.rar Технологическая платформа 1С:Предприятия для Windows .
Цитата
Светлана Сулименко написал:
Дмитрий, система управления оборудованием ставится на машину, к которой подключается оборудование. Сервер лицензирования на машину, в которую установлен ключ от Альфа-Авто (или активирован, если он программный).
Цитата
Светлана Сулименко написал:
Дмитрий, у Вас установлена https://releases.1c.ru/version_file?nick=Platform83&ver=8.3.12.1412&path=Platform\8_3_12_1412\windows64full.rar Технологическая платформа 1С:Предприятия (64-bit) для Windows . да, поставьте обе, но запускайте именно 32.
Цитата
Юрий написал:
Светлана Рожок пишет:
При первом запуске программы необходимо зарегистрировать компоненту RarusEquipment.dll. Можно зарегистрировать разными способами.Это не первый запуск.
Причина не может быть в необходимости регистрации компоненты при первом запуске, т.к. на других серверах новый пользователь прекрасно входит без регистрации компоненты, которая регистрируется на компьютере, а не для конкретного пользователя, кстати.

Причины, видимо, глубоко уходят в область системного администрирования. Рецептов решения крайне мало и все они не помогают. Поэтому считаю важным предложить практически работающий способ. Прикрепляю 2 файла, содержимое которых также цитирую. Внести в реестр пользователя.

——————
Windows Registry Editor Version 5.00

——————
Windows Registry Editor Version 5.00

Источник статьи: http://rarus.ru/forum/forum7/topic5726/?PAGEN_1=3

Ошибка загрузки компоненты управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Альфа-Авто:Автосалон+Автосервис+Автозапчасти Проф, редакция 5

Имеется терминальный сервер S1 которому подключены с помощью удрабстола пользователи домена A и B. Пользователь домена A не испытывает никаких проблем при запуске Альфа-Авто. У пользователя домена B при запуске возникает ошибка «Ошибка при загрузке компоненты управления оборудованием: <Обработка.Защита.МодульОбъекта(24)>: Ошибка при вызове метода контекста (ЗагрузитьВнешнююКомпоненту): ошибка при загрузке внешней компоненты».

Система защиты конфигурации Альфа-Авто установлена на этом же сервере S1. Права пользователей домена одинаковые (пользователь B создан копированием пользователя А в оснастке AD), доступ к папке C:\ProgramData\Protect\LocalProtect имеется для всех пользователей домена.

Пользователь B не может зайти в Альфа-Авто ни под одним пользователем Альфа-Авто, в том числе под Администратором Альфа-Авто. Также не помогает временное предоставление пользователю домена B прав администратора домена.

Прошу помочь в решении проблемы

Цитата
Светлана Рожок пишет:
При первом запуске программы необходимо зарегистрировать компоненту RarusEquipment.dll. Можно зарегистрировать разными способами.

Это не первый запуск.
Причина не может быть в необходимости регистрации компоненты при первом запуске, т.к. на других серверах новый пользователь прекрасно входит без регистрации компоненты, которая регистрируется на компьютере, а не для конкретного пользователя, кстати.

Причины, видимо, глубоко уходят в область системного администрирования. Рецептов решения крайне мало и все они не помогают. Поэтому считаю важным предложить практически работающий способ. Прикрепляю 2 файла, содержимое которых также цитирую. Внести в реестр пользователя.

——————
Windows Registry Editor Version 5.00

——————
Windows Registry Editor Version 5.00

Добрый день!! Не помогает ни один из вариантов. У меня тоже самое, за исключением МодульОбъекта(25) и пользователи заходят, но без оборудования. Виндовс 8.1, платформа 8.3.5.1460, конфигурация Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1 (5.1.01.05). При этом при попытке перерегистрации компоненты через regsvr32 конфигурация вообще отказывается работать, пишет конфигурация оборудования не найдена 1% и бесконечный поиск — после перерегистрации помогает только переустановка платформы. Пробовал на более свежей платформе, но там еще докучи и ошибка потока при заходе в базу нескольких пользователей.

Обновлять конфигурацию пока побаиваюсь, понимаю, что дело тут совсем не в платформе и не в конфигурации, а в самом виндовсе, но никак проблему решить не могу. Причем есть в локальной сети один компьютер у которого все работает без ошибок с той-же самой операционной системой, но вот в чем разница непонятно.

Цитата
Светлана Сулименко пишет:
Роман, необходимо к Вам удаленно подключиться для решения ситуации на месте. Вышлите, пожалуйста, на alfa@rarus.ru контактные данные и удобное для Вас время подключения со ссылкой на данную ветку форума.

В итоге справился своими силами. Не знаю что уж там у меня было не так, но технология с плясками такая получилась :

Источник статьи: http://rarus.ru/forum/forum7/topic5726/

Ошибка загрузки компоненты управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора?
Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора

При первом запуске программы 1С-Рарус: Управление отелем необходимо выполнить запуск Платформы 1С от имени Администратора.

Добрый день! У нас аналогичная проблема.
Конфигурация Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1 (5.1.07.14)
Библиотеку RarusEquipment.dll зарегистрировали от имени администратора (версия библиотеки 8.0.6.17).

Подскажите, пожалуйста, как нам еще можно попробовать решить проблему?

Светлана, пока не возможности попробовать удалить папку.

Поясните, пожалуйста, как удаление папки поможет в решении данной проблемы? Как же 1С будет запускаться, если мы удалим папку, в которую она установлена и из которой запускается?

Заранее спасибо за пояснения!

Светлана, удалять папку нам было нельзя, т.к. была установлена 64-разрядная платформа и удаление папки привело бы к невозможности запуска 1С.

Но ваш ответ натолкнул нас на мысль, что видимо проблема как раз в том, что у нас 64-разрядная платформа и видимо компонента не работает под 64-разр. платформой.

Мы установили 32-разрядную платформу и ошибка ушла без каких-либо доп. действий.

Возможно, необходимо прописать данную особенность в документации к ПП.

Цитата
Светлана Сулименко написал:
Да, Михаил, при удалении файла config.xml оборудование нужно будет устанавливать заново.
при повторной установке RarusEqupment.exe оборудование не затирается.
Цитата
Светлана Сулименко написал:
Михаил, у Вас неправильно установлена платформа 1С. Платформу нужно ставить общую для ОС windows, а она уже при установке определит битность ОС.

Долго мучался с похожей проблемой в УАТ.
При использовании платформы версии 8.3.9.1818, при запуске УАТ выходила ошибка.
Что не удалось зарегистрировать компоненту V8UATProf.dll
Оказалось что у меня стояла 64x версия 1С (8.3.9.1818).
Которая находилась по адресу (C:\Program Files\1cv8)
Удалил по вашему совету папку 1cv8

Скачал 32x версию той же платформы (8.3.9.1818).
Установилась по адресу (C:\Program Files (x86)), где лежат и остальные версии платформ.
Теперь УАТ запускается нормально.

Добрый день. Ошибка при загрузке компоненты управления оборудованием:
https://yadi.sk/i/9dojfTxC3SmcDS

Windows10 64-bit, 1С:Предприятие 8.3 (8.3.11.2924), 64-bit. В C:\Program Files (x86)\ папки 1сv8 нет.
Проделали все вышеописанные рекомендации. Ставить 32-разрядную платформу правда пока не стали.
Подскажите как решить данную проблему на 64 битной платформе.

Источник статьи: http://rarus.ru/forum/forum7/topic5726/message66354/

Ошибка загрузки компоненты управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора?
Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора

При первом запуске программы 1С-Рарус: Управление отелем необходимо выполнить запуск Платформы 1С от имени Администратора.

Добрый день! У нас аналогичная проблема.
Конфигурация Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1 (5.1.07.14)
Библиотеку RarusEquipment.dll зарегистрировали от имени администратора (версия библиотеки 8.0.6.17).

Подскажите, пожалуйста, как нам еще можно попробовать решить проблему?

Светлана, пока не возможности попробовать удалить папку.

Поясните, пожалуйста, как удаление папки поможет в решении данной проблемы? Как же 1С будет запускаться, если мы удалим папку, в которую она установлена и из которой запускается?

Заранее спасибо за пояснения!

Светлана, удалять папку нам было нельзя, т.к. была установлена 64-разрядная платформа и удаление папки привело бы к невозможности запуска 1С.

Но ваш ответ натолкнул нас на мысль, что видимо проблема как раз в том, что у нас 64-разрядная платформа и видимо компонента не работает под 64-разр. платформой.

Мы установили 32-разрядную платформу и ошибка ушла без каких-либо доп. действий.

Возможно, необходимо прописать данную особенность в документации к ПП.

Цитата
Светлана Сулименко написал:
Да, Михаил, при удалении файла config.xml оборудование нужно будет устанавливать заново.
при повторной установке RarusEqupment.exe оборудование не затирается.
Цитата
Светлана Сулименко написал:
Михаил, у Вас неправильно установлена платформа 1С. Платформу нужно ставить общую для ОС windows, а она уже при установке определит битность ОС.

Долго мучался с похожей проблемой в УАТ.
При использовании платформы версии 8.3.9.1818, при запуске УАТ выходила ошибка.
Что не удалось зарегистрировать компоненту V8UATProf.dll
Оказалось что у меня стояла 64x версия 1С (8.3.9.1818).
Которая находилась по адресу (C:\Program Files\1cv8)
Удалил по вашему совету папку 1cv8

Скачал 32x версию той же платформы (8.3.9.1818).
Установилась по адресу (C:\Program Files (x86)), где лежат и остальные версии платформ.
Теперь УАТ запускается нормально.

Добрый день. Ошибка при загрузке компоненты управления оборудованием:
https://yadi.sk/i/9dojfTxC3SmcDS

Windows10 64-bit, 1С:Предприятие 8.3 (8.3.11.2924), 64-bit. В C:\Program Files (x86)\ папки 1сv8 нет.
Проделали все вышеописанные рекомендации. Ставить 32-разрядную платформу правда пока не стали.
Подскажите как решить данную проблему на 64 битной платформе.

Источник статьи: http://rarus.ru/forum/forum7/topic5726/message66416/

Ошибка загрузки компоненты управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора?
Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора

При первом запуске программы 1С-Рарус: Управление отелем необходимо выполнить запуск Платформы 1С от имени Администратора.

Добрый день! У нас аналогичная проблема.
Конфигурация Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1 (5.1.07.14)
Библиотеку RarusEquipment.dll зарегистрировали от имени администратора (версия библиотеки 8.0.6.17).

Подскажите, пожалуйста, как нам еще можно попробовать решить проблему?

Светлана, пока не возможности попробовать удалить папку.

Поясните, пожалуйста, как удаление папки поможет в решении данной проблемы? Как же 1С будет запускаться, если мы удалим папку, в которую она установлена и из которой запускается?

Заранее спасибо за пояснения!

Светлана, удалять папку нам было нельзя, т.к. была установлена 64-разрядная платформа и удаление папки привело бы к невозможности запуска 1С.

Но ваш ответ натолкнул нас на мысль, что видимо проблема как раз в том, что у нас 64-разрядная платформа и видимо компонента не работает под 64-разр. платформой.

Мы установили 32-разрядную платформу и ошибка ушла без каких-либо доп. действий.

Возможно, необходимо прописать данную особенность в документации к ПП.

Цитата
Светлана Сулименко написал:
Да, Михаил, при удалении файла config.xml оборудование нужно будет устанавливать заново.
при повторной установке RarusEqupment.exe оборудование не затирается.
Цитата
Светлана Сулименко написал:
Михаил, у Вас неправильно установлена платформа 1С. Платформу нужно ставить общую для ОС windows, а она уже при установке определит битность ОС.

Долго мучался с похожей проблемой в УАТ.
При использовании платформы версии 8.3.9.1818, при запуске УАТ выходила ошибка.
Что не удалось зарегистрировать компоненту V8UATProf.dll
Оказалось что у меня стояла 64x версия 1С (8.3.9.1818).
Которая находилась по адресу (C:\Program Files\1cv8)
Удалил по вашему совету папку 1cv8

Скачал 32x версию той же платформы (8.3.9.1818).
Установилась по адресу (C:\Program Files (x86)), где лежат и остальные версии платформ.
Теперь УАТ запускается нормально.

Добрый день. Ошибка при загрузке компоненты управления оборудованием:
https://yadi.sk/i/9dojfTxC3SmcDS

Windows10 64-bit, 1С:Предприятие 8.3 (8.3.11.2924), 64-bit. В C:\Program Files (x86)\ папки 1сv8 нет.
Проделали все вышеописанные рекомендации. Ставить 32-разрядную платформу правда пока не стали.
Подскажите как решить данную проблему на 64 битной платформе.

Источник статьи: http://rarus.ru/forum/forum7/topic5726/?PAGEN_1=2

Ошибка загрузки компоненты управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора?
Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора

При первом запуске программы 1С-Рарус: Управление отелем необходимо выполнить запуск Платформы 1С от имени Администратора.

Добрый день! У нас аналогичная проблема.
Конфигурация Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1 (5.1.07.14)
Библиотеку RarusEquipment.dll зарегистрировали от имени администратора (версия библиотеки 8.0.6.17).

Подскажите, пожалуйста, как нам еще можно попробовать решить проблему?

Светлана, пока не возможности попробовать удалить папку.

Поясните, пожалуйста, как удаление папки поможет в решении данной проблемы? Как же 1С будет запускаться, если мы удалим папку, в которую она установлена и из которой запускается?

Заранее спасибо за пояснения!

Светлана, удалять папку нам было нельзя, т.к. была установлена 64-разрядная платформа и удаление папки привело бы к невозможности запуска 1С.

Но ваш ответ натолкнул нас на мысль, что видимо проблема как раз в том, что у нас 64-разрядная платформа и видимо компонента не работает под 64-разр. платформой.

Мы установили 32-разрядную платформу и ошибка ушла без каких-либо доп. действий.

Возможно, необходимо прописать данную особенность в документации к ПП.

Цитата
Светлана Сулименко написал:
Да, Михаил, при удалении файла config.xml оборудование нужно будет устанавливать заново.
при повторной установке RarusEqupment.exe оборудование не затирается.
Цитата
Светлана Сулименко написал:
Михаил, у Вас неправильно установлена платформа 1С. Платформу нужно ставить общую для ОС windows, а она уже при установке определит битность ОС.

Долго мучался с похожей проблемой в УАТ.
При использовании платформы версии 8.3.9.1818, при запуске УАТ выходила ошибка.
Что не удалось зарегистрировать компоненту V8UATProf.dll
Оказалось что у меня стояла 64x версия 1С (8.3.9.1818).
Которая находилась по адресу (C:\Program Files\1cv8)
Удалил по вашему совету папку 1cv8

Скачал 32x версию той же платформы (8.3.9.1818).
Установилась по адресу (C:\Program Files (x86)), где лежат и остальные версии платформ.
Теперь УАТ запускается нормально.

Добрый день. Ошибка при загрузке компоненты управления оборудованием:
https://yadi.sk/i/9dojfTxC3SmcDS

Windows10 64-bit, 1С:Предприятие 8.3 (8.3.11.2924), 64-bit. В C:\Program Files (x86)\ папки 1сv8 нет.
Проделали все вышеописанные рекомендации. Ставить 32-разрядную платформу правда пока не стали.
Подскажите как решить данную проблему на 64 битной платформе.

Источник статьи: http://rarus.ru/forum/forum7/topic5726/message66330/

Ошибка загрузки компоненты управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора?
Цитата
Светлана Сулименко написал:
Максим, регистрацию компоненты делали от имени пользователя с правами администратора

При первом запуске программы 1С-Рарус: Управление отелем необходимо выполнить запуск Платформы 1С от имени Администратора.

Добрый день! У нас аналогичная проблема.
Конфигурация Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1 (5.1.07.14)
Библиотеку RarusEquipment.dll зарегистрировали от имени администратора (версия библиотеки 8.0.6.17).

Подскажите, пожалуйста, как нам еще можно попробовать решить проблему?

Светлана, пока не возможности попробовать удалить папку.

Поясните, пожалуйста, как удаление папки поможет в решении данной проблемы? Как же 1С будет запускаться, если мы удалим папку, в которую она установлена и из которой запускается?

Заранее спасибо за пояснения!

Светлана, удалять папку нам было нельзя, т.к. была установлена 64-разрядная платформа и удаление папки привело бы к невозможности запуска 1С.

Но ваш ответ натолкнул нас на мысль, что видимо проблема как раз в том, что у нас 64-разрядная платформа и видимо компонента не работает под 64-разр. платформой.

Мы установили 32-разрядную платформу и ошибка ушла без каких-либо доп. действий.

Возможно, необходимо прописать данную особенность в документации к ПП.

Цитата
Светлана Сулименко написал:
Да, Михаил, при удалении файла config.xml оборудование нужно будет устанавливать заново.
при повторной установке RarusEqupment.exe оборудование не затирается.
Цитата
Светлана Сулименко написал:
Михаил, у Вас неправильно установлена платформа 1С. Платформу нужно ставить общую для ОС windows, а она уже при установке определит битность ОС.

Долго мучался с похожей проблемой в УАТ.
При использовании платформы версии 8.3.9.1818, при запуске УАТ выходила ошибка.
Что не удалось зарегистрировать компоненту V8UATProf.dll
Оказалось что у меня стояла 64x версия 1С (8.3.9.1818).
Которая находилась по адресу (C:\Program Files\1cv8)
Удалил по вашему совету папку 1cv8

Скачал 32x версию той же платформы (8.3.9.1818).
Установилась по адресу (C:\Program Files (x86)), где лежат и остальные версии платформ.
Теперь УАТ запускается нормально.

Добрый день. Ошибка при загрузке компоненты управления оборудованием:
https://yadi.sk/i/9dojfTxC3SmcDS

Windows10 64-bit, 1С:Предприятие 8.3 (8.3.11.2924), 64-bit. В C:\Program Files (x86)\ папки 1сv8 нет.
Проделали все вышеописанные рекомендации. Ставить 32-разрядную платформу правда пока не стали.
Подскажите как решить данную проблему на 64 битной платформе.

Источник статьи: http://rarus.ru/forum/forum7/topic5726/message66555/

АльфаАвто 4: Ошибка при загрузке внешней компоненты

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Добрый день, история такая:
Раньше пользовались АльфаАвто 4: Автосервис+Автозапчасти, позднее перешли на 1С Предприятие 8: Автосервис, сменили сервер.

Сейчас понадобилось достать пару выписок и сверок из старой альфы, для чего был развернут бекап. Но при установке системы защиты(для открытия базы) возникли проблемы. Во-первых, во время установки сервера защиты программа установки виснет намертво на стадии «обновление библиотек», связано это или нет, но последующий запуск базы и указание месторасположения компонентов защиты дает это:

Проверено и на сервере (windows server 2019 standart), и на обычной рабочей станции (windows 10 Pro)
Подскажите куда копать.
Заранее спасибо.

p.s. ключ аппаратный(usb) версия конфигурации 4.1.01.26, все установки из дистрибутива этой версии.

Для получения актуального установочного дистрибутива системы защиты необходимо направить запрос на электронный адрес alfa@rarus.ru . В тексте запроса указать регистрационный номер основной поставки Альфа-Авто и ссылку на эту ветку Форума. В письме также просьба добавить скриншоты ключа защиты из диспетчера устройств и утилиты Ключи защиты в Панели управления.
Ошибка на скриншоте также может возникать, если для запуска решения используется 64-битная платформа 1С 8.3. Обращаем Ваше внимание, что Альфа-Авто ред.4 была адаптирована под работу на Платформе 8.2 и для запуска решения необходимо использовать ее.

Цитата
Валентина Кузнецова написал:
Добрый день, Павел!

Для получения актуального установочного дистрибутива системы защиты необходимо направить запрос на электронный адрес mailto:alfa@rarus.ru alfa@rarus.ru . В тексте запроса указать регистрационный номер основной поставки Альфа-Авто и ссылку на эту ветку Форума. В письме также просьба добавить скриншоты ключа защиты из диспетчера устройств и утилиты Ключи защиты в Панели управления.
Ошибка на скриншоте также может возникать, если для запуска решения используется 64-битная платформа 1С 8.3. Обращаем Ваше внимание, что Альфа-Авто ред.4 была адаптирована под работу на Платформе 8.2 и для запуска решения необходимо использовать ее.

Цитата
Да у меня есть актуальные дистрибутивы, просто я счел правильным делать установку с той же версии, на которой база.

Нужно проводить установку из дистрибутива, в котором компонента для Вашего релиза, а библиотека обновлена для более актуальных версий Windows. Его можно получить только в индивидуальном порядке запросом на почту.

Цитата
Да у меня есть актуальные дистрибутивы, просто я счел правильным делать установку с той же версии, на которой база.

Нужно проводить установку из дистрибутива, в котором компонента для Вашего релиза, а библиотека обновлена для более актуальных версий Windows. Его можно получить только в индивидуальном порядке запросом на почту.

Запустил на 8.2 и с 32-битным клиентом.
Однако ранее она точно работала на 8.3 и с 64-битным клиентом

Источник статьи: http://rarus.ru/forum/forum17/topic14306/

Обновление альфы-авто

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Цитата
Михаил Устюгов пишет:

Скажите, а как установить два релиза с разными системами защиты?

Я хочу оставить свой рабочий (4.1.01.08) и поставить для проверки последний (4.1.01.16), как это сделать?

Распишу подробно. В разных случаях порядок и состав пунктов может отличатся. Тут общие принципы.

1. Копируем рабочую базу в другой каталог (каталог тестовой базы).

2. Запускаем тестовую базу в режиме предприятия.

3. В тестовой базе в справочнике компьютеров у текущего компьютера выбираем новый каталог «Локальный каталог системы защиты».

4. Перезапускаем тестовую базу в режиме предприятия. Собственно с сервера защиты в новый локальный каталог защиты копируются файлы с сервера. Сервер остается одинаковый для всех баз.

5. Закрываем тестовую базу.

6. В локальном каталоге системы защиты тестовой базы (из п.3) создаем текстовый файл с именем block.tmp. В этом файле перечисляем имена файлов, которые не требуется загружать с сервера. В данном случае достаточно V8AutoService.dll или V8AutoSalon.dll (или другой файл компоненты защиты — смотря что за конфигурация).

7. В режиме конфигуратора обновляем конфигурацию тестовой базы до нужного релиза.

8. В локальный каталог системы защиты (п.3) тестовой базы помещаем компоненту защиты нового (тестируемого) релиза V8AutoService.dll или V8AutoSalon.dll или .

9. Собственно запускаем тестовую базу в режиме предприятия с новым релизом. При этом с сервера компонента от старого релиза подгружена не будет.

Общая идея данного описания. Как переключить работу базы на локальный каталог защиты отличный от значения по умолчанию. Как запретить загрузку тех или иных файлов с сервера в локальный каталог.

Добрый день! У нас лицензионный продукт Альфа-Авто: А-А-А. Клиент-Серверный вариант.Собственно,5 экземпляров по области. Рабочий релиз 05.
Сейчас,пробуем протестировать 17 или 19 релиз,чтобы изучить возможность перехода на них. Следуем по Вашей инструкции,т.е. в спр-ке Компьютеры указали ЛокальныйКаталогЗащиты,создали файл block.tmp c V8AutoService.dll .
При загрузке Предприятия выдается сообщение :
При старте подсистемы защиты и управления оборудованием возникла ошибка:
и в окне красным
List index out of bounds (0)
Спасибо.

Цитата
Николай Денисов пишет:
При старте подсистемы защиты и управления оборудованием возникла ошибка:
и в окне красным
и в окне красным
List index out of bounds (0)
Цитата
Николай Денисов пишет:

При старте подсистемы защиты и управления оборудованием возникла ошибка:

List index out of bounds (0)

Нужно уточнение. На каком релизе выдает это сообщение? 05, 17, 19? (надеюсь что релиз 05 это 4.1.01.05 ? )

Какие версии компоненты используются для указанных релизов?

На всякий случай выкладываю последнюю компоненту (еще не опубликованная) 8.0.7.110. Попробуйте ее подусунуть к 19 релизу.

Добрый день!
Клиент-серверный вариант. Сервер 1с Предприятие.Релиз ААА 4.1.01.05
Сервер защиты 1.1.2.970
Ключ Рарус на сервере.
На локальном компьютере релиз 4.1.01.05 поднимаю до релиза 4.1.01.10,каждый раз запускаю предприятию поднятого релиза.
Теперь надо релиз 10 поднять на 11.
Далее в справочнике Компьютеры для данного локального компьютера изменяю реквизит Локальный каталог защиты на Свой.
В локальном каталоге защиты Свой создаю текстовый файл block.tmp,в который заношу имя компоненты V8AutoSalon.dll .
— Надо ли запускать установку системы защиты для 11 релиза?
Я запускаю установку системы защиты на своем локальном компе. Мастер установки защиты создает C:\Documents and Settings\All Users\Application Data\Protect\LocalProtect.(Но этот каталог перезаполнится при запуске рабочей базы)
Надо ли файлы из этого каталога переносить в свой локальный? Если я правильно понимаю,то с сервера защиты скопируются все файлы в локальный каталог,кроме компоненты,указанной в block.tmp,то есть V8AutoSalon.dll.
Делаю так. Удаляю каталог C:\Documents and Settings\All Users\Application Data\Protect\LocalProtect.
А в Локальном каталоге защиты есть только компонента V8AutoSalon.dll (11 релиза) и файл block.tmp.
Запускаю предприятие.
Выдается сообщение о первом запуске и вызывается Мастер настройки системы защиты.
Варианты выбора:
1- Компонента защиты и ключ установлены на данном компьютере? — НЕТ,ключ и защита (на рабочую версию) установлены на сервере
2- Система защиты и ключ установлены на другом компе или Серевере? (Да-на сервере у нас)
3- Система защиты еще не установлена,необходимо установить на данный комп.

Что выбрать? Выбираю 2 — ключи и защита на сервере,полагая что файлы защиты будут копироваться с сервера в локальный каталог,кроме компоненты V8AutoSalon.dll (11 релиза) указанной в файле block.tmp.
Указываю имя сервера. Мастер предлагает указать каталог,где будут располагаться файлы защиты. Указываю Свой Локальный каталог защиты.
Идет копирование файлов и выдается сообщение:
При старте подсистема защиты и управления оборудованием возникла ошибка
List index out of bounds (0)

Помогите,пожалуйста. Хочется протестировать новые релизы,прежде чем переходить на них. Обновлять систему защиты на сервере боязно-вдруг встанет работа. Спасибо.

АА 5, релиз 5.0.13.05.
Платформа 8.2.18.109

Пытаюсь обновить альфу (изначально релиз был еще меньше, то есть несколько обновлений село норм). Дошел до релиза 5.0.13.05 и всё, дальше не идет. Во время обновления выходит ошибка — скрин.
Подумал, что дело в платформе. Обновил до 8,2,19,130 (последняя из 8,2). Но данная платформа, почему-то, не видит ключа (хотя старая платформа запускается без проблем).

Что может быть? Как мне дальше продолжить обновление?

Цитата
Артём Бавенд пишет:
Здравстуйте.

АА 5, релиз 5.0.13.05.
Платформа 8.2.18.109

Пытаюсь обновить альфу (изначально релиз был еще меньше, то есть несколько обновлений село норм). Дошел до релиза 5.0.13.05 и всё, дальше не идет. Во время обновления выходит ошибка — скрин.
Подумал, что дело в платформе. Обновил до 8,2,19,130 (последняя из 8,2). Но данная платформа, почему-то, не видит ключа (хотя старая платформа запускается без проблем).

Источник статьи: http://rarus.ru/forum/forum7/topic115/message59853/

не обнаружены файлы драйверов системы управления оборудованием

Внимание! Данный форум является модерируемым.
Для получения к нему доступа необходимо зарегистрироваться или авторизоваться на сайте.

Windows 10 x64
Платформа 1С:Предприятие 8.3 (8.3.17.2231) (32 разрядная)
Конфигурация Альфа-Авто: Автосалон+Автосервис+Автозапчасти ПРОФ, редакция 5.1 (5.1.27.04)
Подключение к базе клиент-серверное (sql), Толстый клиент.

необходимо подключить сканер штрихкода.
В справочнике «Рабочие места (компьютеры)» был указан путь к драйверам по умолчанию «C:\ProgramData\Protect\LocalProtect\»

После перезапуска 1С выходит ошибка:
При проверке каталога системы управления оборудованием С:\\. были обнаружены ошибки.
Не обнаружены файлы драйверов системы управления оборудованием.

Что было сделано:
Скачен с сайта техподдержки Рарус файл «Пакет драйверов по технологии Рарус» или «RarusEquipmentSetup».
Установлены с этого пакета драйвера на сканеры. Запуск 1С выдал ту же ошибку.

Далее 1С запущена из-под администратора, вышла прежняя ошибка.
Нажал «ДА» и перешел на помощника установки драйверов, выбрал скаченный файл пакета от Раруса после в установке выбрал драйвера сканеров.
После окончания установки снова запустил 1С из-под Администратора, 1С выдала ту же самую ошибку «не находит файлы управления. «.
Регистрация библиотеки RarusEquipmentSetup.dll была проведена.

Светлана, добрый день. Нет, не устанавливал. Компьютер достался мне уже с подключенной АА в клиент-серверном варианте.
Где я могу скачать дистрибутив «Системы управления оборудованием»? Боюсь установочный диск не факт, что смогу найти.

Скопировал содержимое «C:\ProgramData\Protect\LocalProtect\» из сервера к себе на компьютер по тому же пути, кроме файла config.
1С АА запустилась без ошибок. Далее в справочнике «Оборудование» добавил клавиатурный сканер (подключенный к пк сканер по юсб, он виден в диспетчере устройств как клавиатура), далее в справочнике «Рабочие места (компьютеры)» в поле сканеры выбрал созданное торговое оборудование.

Но в статусе торгового оборудования выходит ошибка «НЕТ ДРАЙВЕРА — Устройство с заданным GUID,ом есть, но не может быть использовано в данный момент. Причина: Плагин оборудования не найден».

Что еще необходимо скачать и установить?
Разве драйвера эти не в скаченном и установленном «Пакет драйверов по технологии Раруса»?
Из этого пакета были установлены все 4 варианта подключения сканеров, все DLL сканеров были зарегистрированы.
Помимо этого также из папки с установленными драйверами «C:\Program Files (x86)\1CEquipment\» были скопированы драйвера в «C:\ProgramData\Protect\LocalProtect\».
Ошибка после перезапуска 1С из-под администратора осталась.

Источник статьи: http://rarus.ru/forum/forum7/topic14933/

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *